Aggiornamento Automatico per Firefox 5 su Ubuntu tramite PPA

Ecco le istruzioni per aggiornare Firefox alla versione 5 su Ubuntu tramite repository PPA – in pochi secondi.

Firefox 5 è stato rilasciato con tante novità descritte in questo articolo e la versione stabile è finalmente disponibile anche nel repository di Mozilla per permettere a tutti gli utenti di Ubuntu l’aggiornamento automatico.

Aggiornare a Firefox 5 in Pochi Secondi

Per l’aggiornamento di Firefox è solo necessario inserire la fonte ufficiale di Mozilla nel tuo sistema con i seguenti comandi da terminale:

sudo add-apt-repository ppa:ubuntu-mozilla-security/ppa
sudo apt-get update
sudo apt-get upgrade

Al termine dell’aggiornamento riavvia Firefox per lanciare la nuova versione.

Se dopo l’aggiornamento non riesci ad configurare Firefox 5 con la Lingua Italiana puoi cliccare su questo collegamento e accettare l’installazione.

Enjoy!

  • Alek Email

    ho seguito la guida ma non ha aggiornato a firefox5

    • http://www.ubuntu-linux.it Andrea Zorzetto

      Ciao Alek, su quale versione di Ubuntu stai facendo l’aggiornamento e quale problema riscontri?

      • Alek Email

        sia nella 10.04 che nella 10.10

        • Alek Email

          Sostanzialmente quando faccio sudo apt-get dist-upgrade non esce nessun aggiornamento

        • http://www.ubuntu-linux.it Andrea Zorzetto

          Ma infatti non devi fare dist-upgrade ma solo upgrade come ho scritto..

  • Simone

    Ciao, ho aggiornato da poco a ubuntu 11.04 e vorrei aggiornare firefox.

    Ho lanciato il primo comando (sudo add-apt-repository ppa:ubuntu-mozilla-security/ppa)
    e mi è comparso:

    Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –secret-keyring /etc/apt/secring.gpg –trustdb-name /etc/apt/trustdb.gpg –keyring /etc/apt/trusted.gpg –primary-keyring /etc/apt/trusted.gpg –keyserver hkp://keyserver.ubuntu.com:80/ –recv AF316E81A155146718A6FBD7A6DCF7707EBC211F
    gpg: richiesta della chiave 7EBC211F dal server hkp keyserver.ubuntu.com
    gpg: chiave 7EBC211F: “Launchpad PPA for Ubuntu Mozilla Security Team” non cambiata
    gpg: Numero totale esaminato: 1
    gpg:              non modificate: 1

    essendo un po’ alle prime armi ho continuato con gli altri due comandi… e voilà, tutto è rimasto come prima.. come posso fare?

    • http://www.ubuntu-linux.it Andrea Zorzetto

      Ok non ci sono errori nel primo comando.. Hai fatto apt-get upgrade dopo?

      Se non sei sicuro chiudi tutte le finestre di Firefox e lancia:
      sudo apt-get update
      sudo apt-get install firefox

      Avviando Firefox dovresti trovarti la nuova versione già installata. Fammi sapere se ci sono errori.

      • Simone

        Grazie della risposta rapidissima! Ho continuato con gli altri comandi e mi dice:

        Lettura elenco dei pacchetti… Fatto
        Generazione albero delle dipendenze      
        Lettura informazioni sullo stato… Fatto
        firefox è già alla versione più recente.
        I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
          kdelibs4c2a xulrunner-1.9.2 ttf-sil-gentium libjpeg8
          language-support-writing-lt libgraphite3 linux-headers-2.6.38-8 libwpg-0.2-2
          kdelibs-data liblualib50 transfig language-support-lt ttf-lyx
          libmythes-1.2-0 libavahi-qt3-1 ttf-sil-gentium-basic
          linux-headers-2.6.38-8-generic libtextcat0 libwps-0.2-2 libtextcat-data gocr
          liblua50 libjpeg-progs libwpd-0.9-9
        Usare “apt-get autoremove” per rimuoverli.
        0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

        Quindi riavviando firefox mi ritrovo il 3.6…

        • http://www.ubuntu-linux.it Andrea Zorzetto

          Simone mi sembra davvero strano perchè praticamente ormai anche nei repositories ufficiali di Natty la versione di Firefox è stata sotituita con la 5. Quindi non capisco proprio cosa succeda..

          L’unica alternativa a questo problema è di andarti a prelevare manualmente i pacchetti di Firefox 5 per il tuo sistema. Se clicchi su questo link vedrai tutta la lista dei pacchetti nel repository di Mozilla PPA:
          http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu/pool/main/f/firefox/

          A seconda del tuo sistema scarica il pacchetto di Firefox 5 aggiornato, ad esempio se il tuo computer ha un normale processore a 32bit scaricherai firefox_5.0+build1+nobinonly-0ubuntu0.11.04.3_i386.deb.

          Nel frattempo lancia questo comando e scrivimi il risultato:
          cat /etc/apt/sources.list.d/ubuntu-mozilla-security-ppa-natty.list

  • Simone
    • http://www.ubuntu-linux.it Andrea Zorzetto

      Allora due notizie:

      1) la buona notizia è che è tutto corretto
      2) la cattiva notizia è che non ha assolutamente senso che ti ritrovi firefox 3

      Se mi mandi un email con il codice team viewer ti do un occhio io.. (ormai faccio pure assistenza online gratis :D )

    • Simone

      quanto alla pagina che mi hai indicato, ho selezionato
      firefox_5.0+build1+nobinonly-0ubuntu0.11.04.3_i386.deb
      e l’ho salvato in una cartella
      ho cliccato sul file scaricato e si è aperto l’Ubuntu Software Center e mi dà questa schermata:

      • Simone

        Non so se è utile saperlo, ma se faccio aiuto/info mozilla firefox dal browser mi dà:

        Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

      • http://www.ubuntu-linux.it Andrea Zorzetto

        Miseria ma non vorrei che tu hai sul sistema iceweasel (non potevi dirmelo prima..)
        Facciamo una cosa lancia questo e dimmi il risultato:

        dpkg -l |grep -i iceweasel

        • Simone

          il comando che mi hai indicato non mi restituisce nulla.. LoL
          mi spiace farti sclerare..
          quanto a team viewer, l’ho usato solo con un amico su windows, non saprei come darti il codice..
           

        • http://www.ubuntu-linux.it Andrea Zorzetto

          mi dispiace non riesco proprio a dirti altro da qui.

  • Simone

    Ti ringrazio lo stesso per l’infinita pazienza! Vedo se trovo qualche amico smanettone che possa venire a darmi una mano! ^^

    • Ritzalberto

      io sono riuscito ad aggiornare alla versione 5 senza problemi. ho ubuntu 11 e avevo firefox 4 .